Port-Channels
A port channel, also known as a link aggregation group or channel group, is a technology that allows multiple physical interfaces to be grouped together into a single logical interface.
This logical interface is used to increase the bandwidth, provide redundancy, and improve the reliability of the network. PortChannels are commonly used in enterprise networks to increase the capacity of the network and to provide redundancy in the event of a link failure. There are several types of PortChannels, including Static PortChannels, Port Aggregation Protocol (PaGP), and Link Aggregation Protocol (LACP). In this blog post, we will discuss each of these types in detail, including their configuration and verification.
Static PortChannel
The "Static" mode is a configuration in which the link aggregation is manually configured without using any protocol such as LACP or PAGP. It is similar to the "On" mode but requires manual configuration on both ends of the link, rather than relying on the ports to be always enabled for link aggregation. This mode is often used in situations where LACP or PAGP is not available or cannot be used
Configuration
- Configure the physical interfaces as L2 or L3 access or trunk ports.
- Create a PortChannel interface and assign a channel number.
- Add the physical interfaces to the PortChannel interface.
Switch(config-if-range)# channel-group 1 mode on
Switch(config-if-range)# switchport mode trunk
Switch(config)# interface Port-Channel 1
Switch(config-if)# switchport mode trunk
Switch(config-if)# spanning-tree portfast trunk
Switch(config-if)# exit
Verification
Link Aggregation Protocol (LACP)
Link Aggregation Control Protocol (LACP) is a standards-based protocol that also dynamically groups multiple physical links into a single logical link. LACP uses a negotiation process to determine if a potential PortChannel partner is capable of supporting LACP. If the partner is capable, LACP will attempt to form a PortChannel. If the partner is not capable, LACP will not form a PortChannel.
Configuration
To configure LACP, follow these steps:
- Configure the physical interfaces as L2 or L3 access or trunk ports.
- Enable LACP on the physical interfaces.
- Create a PortChannel interface and assign a channel number.
Here is an example configuration for an LACP PortChannel using two physical interfaces (Ethernet 1/1 and Ethernet 1/2) and channel number 1:
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# channel-group 1 mode active
Switch(config-if-range)# exit
Switch(config)# interface Port-Channel 1
Switch(config-if)# switchport mode trunk
Switch(config-if)# spanning-tree portfast trunk
Switch(config-if)# exit
Modes in LACP
Verification
Switch# show etherchannel summary
Port Aggregation Protocol (PaGP)
Configuration
- Configure the physical interfaces as L2 or L3 access or trunk ports.
- Enable PaGP on the physical interfaces.
- Create a PortChannel interface and assign a channel number.
Switch(config)# interface range Ethernet 1/1 - 2
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# channel-group 1 mode desirable
Switch(config-if-range)# exit
Switch(config)# interface Port-Channel 1
Switch(config-if)# switchport mode trunk
Switch(config-if)# spanning-tree portfast trunk
Switch(config-if)# exit
Modes in PaGP
Verification
Switch# show etherchannel summary
0 comments:
Post a Comment